THE FORUM IS IN READ-ONLY MODE

This forum is in read-only mode. The new forum is live at https://discourse.openbullet.dev and registrations are open!

Unable to send email using TCP



  • Hello,

    I am trying to send an email using TCP, and its working in regular TELNET but not in OpenBullet.
    It gets stuck on DATA\r\n

    Config

    #Connect_to_GMAIL TCP Connect "smtp.gmail.com" "465" 
    
    TCP Send "HELO hellogoogle\\r\\n" 
    
    #Initiate_Login TCP Send "AUTH LOGIN\\r\\n" 
    
    #Send_User_[base64] TCP Send "MY EMAIL BASE64\\r\\n" 
    
    #Send_Pass_[base64] TCP Send "MY PASS BASE64\\r\\n" 
    
    #MAIL_FROM TCP Send "MAIL FROM: < my gmail >\\r\\n" 
    
    #MAIL_TO TCP Send "RCPT TO: <my gmail>\\r\\n" 
    
    #MAIL_TO2 TCP Send "DATA\\r\\n" 
    
    #SUBJECT TCP Send "SUBJECT: Test\\r\\n" 
    
    #MESSAGE TCP Send "My first mail via telnet.\\r\\n" 
    
    
    

    Debugger

    Succesfully connected to host smtp.gmail.com on port 465. The server says:
    220 smtp.gmail.com ESMTP n20sm5207233edr.89 - gsmtp
    
    > HELO hellogoogle\r\n
    > 250 smtp.gmail.com at your service
    
    > AUTH LOGIN\r\n
    > 334 VXNlcm5hbWU6
    
    > MY EMAIL BASE64\r\n
    > 334 UGFzc3dvcmQ6
    
    > MY PASS BASE64\r\n
    > 235 2.7.0 Accepted
    
    > MAIL FROM: < myemail >\r\n
    > 250 2.1.0 OK n20sm5207233edr.89 - gsmtp
    
    > RCPT TO: <myemail>\r\n
    > 250 2.1.5 OK n20sm5207233edr.89 - gsmtp
    
    > DATA\r\n
    > 354  Go ahead n20sm5207233edr.89 - gsmtp
    
    
    
    
    

    I used the following GUIDE to achieve this: https://www.instructables.com/Send-an-email-via-telnet/



  • Fixed using Subject: test\r\nTestMessage\r\n.\r\n

    \r = ENTER/Return

    #closed


Log in to reply