THE FORUM IS IN READ-ONLY MODE

This forum is in read-only mode. The new forum is live at https://discourse.openbullet.dev and registrations are open!

WebKitFormBoundary get POST code



  • Hello,
    I'm unable to get the POST code of a site. Tried many things but website always tells me that the label is empty.

    ------WebKitFormBoundaryfTOqIudNJLL4zOW4
    Content-Disposition: form-data; name="rv"
    
    true
    


  • That's a multi part Post request.
    You can use it in the Standard way by just replacing the new line by \n



  • @Fairy

    So instead of:

    ------WebKitFormBoundaryfTOqIudNJLL4zOW4
    Content-Disposition: form-data; name="rv"
    
    true
    ------WebKitFormBoundaryfTOqIudNJLL4zOW4--
    

    I do this ?:

    ------WebKitFormBoundaryfTOqIudNJLL4zOW4 \n Content-Disposition: form-data; name="rv" \n \n true \n ------WebKitFormBoundaryfTOqIudNJLL4zOW4-- \n Content-Disposition: form-data; name
    
    and so on ...
    


  • Try without spaces between the data



  • And make this on the whole postData content



  • @Fairy

    I tried but still

    <li>Value is required and cannot be empty.</li>
    

    This is my post code atm:

    ------WebKitFormBoundaryfTOqIudNJLL4zOW4 \nContent-Disposition: form-data; name="username" \n\n<USER> \n------WebKitFormBoundaryfTOqIudNJLL4zOW4 \nContent-Disposition: form-data; name="password" \n\n<PASS> \n------WebKitFormBoundaryfTOqIudNJLL4zOW4 \nContent-Disposition: form-data; name="rv" \n\ntrue \n------WebKitFormBoundaryfTOqIudNJLL4zOW4--
    

    I just checked and the code after "WebKitFormBoundary" so "fTOqIudNJLL4zOW4" is changing when I use the site manualy. I guess I have to capture it somehow but still dont know how to since its first apperance is in "Requested Headers" 😕

    Thanks for your help anyways 🙂



  • It doesn't matter if the code of the mult-ipart is changing.
    1- when you get the data in Fiddler or any debugging tool, take the headers and put them as they are in OB.
    2- the mult-ipart Content-Type should be the same as the mult-ipart in the PostContent
    3- copy the PostContent in a notepad and replace New line with \n
    4- replace the username or email with <USER> and the password with <PASS> and the CSRF Token of there's any
    5- you should be able to get the same Response Data as the one in the debugging tool.



  • If you can't figure things out still, DM me



  • your postdata must be like this:

    #LOGIN REQUEST POST "URL" Multipart

    STRINGCONTENT "username: <USER>"
    STRINGCONTENT "password: <PASS>"
    STRINGCONTENT "g-recaptcha-response: <SOLUTION>"
    STRINGCONTENT "next: URL/"
    BOUNDARY "-----------------------------25395937272913439328812770583"

    it's an example with recaptcha but it can be without ...you have to see with F12



  • Fairy was able to help me so all credits go to Fairy here 😘
    This is the Post code:

    -----------------------------425310358140015617602105346926\nContent-Disposition: form-data; name="username"\n\n<USER>\n-----------------------------425310358140015617602105346926\nContent-Disposition: form-data; name="password"\n\n<PASS>\n-----------------------------425310358140015617602105346926\nContent-Disposition: form-data; name="rv"\n\ntrue\n-----------------------------425310358140015617602105346926--\n
    

    and the following you have to enter as content-type:

    multipart/form-data; boundary=---------------------------425310358140015617602105346926
    

    so the content type is not the type of the POST request (json file in this case)


Log in to reply